
 

 

 

 

Advanced Substation Alpha 

Merging and Muxing Guide 

Author: OblivionShadow 

Revision: v0 8/8/2016 

 

 

 

 

 

 

 

 

 

 

 

 

Note: The merging section of this guide uses a largely manual method of merging which 

is accurate to Aegisub 3.2.2 and Aegisub r8898. 
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1. Overview  

1.1 What is Merging? 

Merging is the process of combining multiple advanced substation alpha files into a 

single file. This process sounds straight forward and relatively speaking it is. There are 

however several details that complicate the process. 

1.2 What is Muxing? 

Muxing is the process of combining various video, audio, and subtitle tracks into the 

Matroska video container. 

1.3 Requisite Programs 

Aegisub Subtitle Editor (Required):  

http://www.aegisub.org/ 

Aegisub Subtitle Editor Trunk Build (Optional/Replaces above): 

http://plorkyeran.com/aegisub/ 

Notepad++ (Required): 

https://notepad-plus-plus.org/ 

MKVToolnix (Required): 

https://www.bunkus.org/blog/ 

AvsPmod (Optional): 

https://avspmod.github.io/ 

MediaInfo (Required): 

https://mediaarea.net/en/MediaInfo 

MKVCleaver (Optional): 

http://www.videohelp.com/software/MKVcleaver 

  

http://www.aegisub.org/
http://plorkyeran.com/aegisub/
https://notepad-plus-plus.org/
https://www.bunkus.org/blog/
https://avspmod.github.io/
https://mediaarea.net/en/MediaInfo
http://www.videohelp.com/software/MKVcleaver
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2. Merging: Color Spaces 

2.1 Standardizing Color Spaces 

One of the most common problems that an inexperienced project leader will make is 

not standardizing the color spaces that their staff uses. If a color is created/sampled in 

the wrong color space, that color will be displayed incorrectly. 

 

Image 1: Comparison between Rec 601 and Rec 709 
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2.2 Checking Color Spaces 

The color space of the video file can be determined via MediaInfo. Generally speaking 

most encoders will use PC/TV.709 however Aegisub by default uses PC/TV.601. 

To use MediaInfo, right click the video file you want to check and click MediaInfo on the 

drop-down menu. 

 

Image 2: Checking video file using MediaInfo 

2.3 Assigning Color Spaces in Aegisub 

You can change the color space that Aegisub uses by going to File -> Properties -> YCbCr 

Matrix. Please note that changing the color space after you have created colors will not 

convert the values to the new color space. To change Aegisub’s default behavior, go to 

View -> Options -> Advanced -> Video -> uncheck Force BT.601. 
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2.4 Shifting Color Spaces 

In the event that a script was created in the wrong color space, you will need to either 

manually sample the colors in the new color space or shift the color space.  

Manually sampling the colors is the best option in terms of accuracy. Manually sampling 

the colors however may be time consuming and require typesetting knowledge. The 

other option is to convert between color spaces using Aegisub’s built in color 

conversion. This can be accessed from Subtitle -> Resample Resolution -> YCbCr Matrix. 

Older versions of Aegisub do not support conversion between color spaces. If you have 

an older version of Aegisub and do not want to update, you can use automation scripts 

such as cmconv.lua to run the color conversion. 

Please note that if you use cmconv.lua to convert between color spaces, you will need 

to manually adjust the project color space to TV.709. Cmconv.lua can be downloaded 

from here https://github.com/Daiz/AegisubMacros. 

 

 

Image 3: Converting between TV.601 and TV.709 using Aegisub’s built in conversion 

https://github.com/Daiz/AegisubMacros
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Image 4: Converting between BT.601 and BT.709 using cmconv.lua 

 

3. Merging: Styles & Dialogue 

3.1.1 Script Consistency 

Before you can start merging any of the various scripts together, you must first 

standardize all of the properties of the script. The easiest method of doing so is to check 

the scripts in Notepad++. The main properties that need to be consistent are the 

PlayRexX/Y and YCbCr Matrix. 

 

Image 5: Example script and style information 
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3.1.2 Adjusting Resolution 

Adjusting the resolution should be done using Aegisub’s resolution resampling tool. This 

is the same tool used in section 2.4 and in image 3. Alternatively, you can open up the 

script in Aegisub and load the video which you want to resize the script to. A window 

should automatically pop up asking if you want to resample the script. 

Please note that some tags such as \orig currently do not scale correctly when the 

resolution is resampled and should be checked after resampling. 

3.1.3 Resampling Color Space 

Resampling the script color space can be done in Aegisub using the built in color 

conversion or by using automation scripts. Please refer to section 2.4  and image 3 for 

more information. 

3.2 Style Conflicts 

Style conflicts occur when you have styles from multiple scripts that have the same 

name but not the same properties. Should multiple styles with the same name exist in 

the same file, the lower style in the file is generally used. The easiest and most straight 

forward way to fix this is to simply rename one of the duplicate styles and all dependent 

lines before you merge the scripts. 

3.3 Dialogue/TS Overlap 

At times, dialogue and typesetting may occupy the same space on the screen. By 

default, dialogue is automatically assigned layer 0. For some typesetting effects 

however, additional layers may be used which may cause the dialogue to be displayed 

under the signs. The easiest way to fix this is to set all of the dialogue lines to a layer 

above the TS or to set it to an arbitrarily high layer. 

 

Image 6: Typesetting overlapping dialogue  
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Merging: Additional Considerations 

4.1.1 [HorribleSubs] Timings 

First things first, [HorribleSubs] should never be used to fine time a show if a different 

encode will be used for the final mux. Even if the final encode uses [HorribleSubs] as the 

source, there may still be timing inconsistencies. 

4.1.2 [HorribleSubs] Removing Header Information 

To date, most [HorribleSubs] releases have incorrect header information in the .mkv 

container. This usually results in the final encode being one frame off from the original 

[HorribleSubs] source. 

To use a [Horriblesubs] video as a work raw for typesetting and karaoke, you will need 

to use MKVCleaver to demux the video and audio files. This completely removes the 

video and audio from the .mkv container. Once demuxed, you can use mkvmerge to 

remux the video and audio files. 

Please note that MKVExtract does not remove the header information from the file. 

 

Image 7: Demuxing video and audio files using MKVCleaver 
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Image 8: Remuxing video and audio track 

4.2 Style Overrides 

One method to bypass style conflicts at script creation time is to write all style 

information within each dialogue line as shown below. Style overrides eliminate the 

problem of having to rename styles however, this method does make it harder to see all 

the required fonts from the raw file itself. 

Please note that while all font information is written in the dialogue line, the original 

style is still required to be displayed correctly. 

 

Image 9: Example of a style override 

4.3 Using Extracted Files 

This section is mainly just to warn about the danger of using extracted files. Some 

demuxing programs such as MKVExtract have been known to incorrectly extract files. 

This can lead to some script information being incorrect and fonts becoming corrupted. 
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5. Merging: Script Cleanup 

5.1 Cleaning up Dialogue 

Once you have merged the scripts, it is recommended that you clean up the script and 

remove extraneous comments. One of the easiest methods to do so is to use 

automation scripts such as unanimated’s ScriptCleanup.lua which can be downloaded 

from here https://github.com/unanimated/luaegisub. 

Please note that US and JP brackets are not the same character and are treated 

differently by aegisub and automation scripts.  

 

Image 10: Using ScriptCleanup.lua to clean up dialogue 

5.2 Removing Garbage Data  

It is also recommended that you remove the aegisub garbage data from your script. 

While this does not impact the subtitles in the final mux, it may contain information 

about file paths in your computer and other information. Removing it also prevents 

warnings from popping up if the script is opened by another person. 

Please note that if the script is opened with aegisub the garbage data will be created 

and thus should be the last step in merging process. 

https://github.com/unanimated/luaegisub
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Image 11: Aegisub garbage data. 

5.3 Extradata 

Starting with aegisub version 3.2, extradata may be created at the bottom of the file. 

This information is mostly used for motion tracking and is not required to view the 

subtitles. It is recommended that you remove the extradata for the final script as it 

makes the script look cleaner and reduces file size. 

 

Image 12: Aegisub extradata 
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6. Muxing 

6.1 Font Collector & Attachments 

Once your file is ready for muxing, you should open the file in aegisub and run the font 

collector to make sure you have all of the required files. This is more reliable than 

looking at the styles themselves as inline override tags may also specify fonts. To access 

the font collector, go to File -> Font Collector -> Check fonts for availability. If you have 

all of the fonts installed, you can also use copy fonts to folder. 

To input fonts into mkvmerge, click on the attachment tab and drag the fonts into input 

files box. 

6.2 Input File Order 

It is recommended that the video file be loaded into mkvmerge before all subtitle tracks. 

In the past, there were occasionally playback problems when subtitles where loaded in 

first. 

6.3 Subtitle Information 

Once you’ve added your subtitle track(s) to mkvmerge, click on each subtitle track to 

edit. Set the language, title, and default track. It is also recommended that you set no 

for forced track as this setting does not always work. Charset should be set to UTF-8 if 

prompted. 

6.4.1 Chapters mkvmerge 

To create chapters using mkvmerge, navigate to the Chapter Editor tab and create a 

new chapter file from Chapter Editor -> New Chapters. Once you’ve created a new 

chapter file, click Add Chapter and add the number of subchapters that you need. Each 

subchapter will be a chapter in the final chapter file. Using Aegisub, find the start time 

of each chapter and copy that time into the start time for the chapter. You do not need 

to set the end time of each chapter. You will also need to set the language and name of 

each chapter. If you will be using ordered chapters, you can also write the Segment UID 

of the video file. When you are done, save the chapters from Chapter Editor -> save. To 

load the chapters into mkvmerge, navigate to the Global tab and add the chapter file 

toward the bottom of the window. 



12 
 

 

Image 13: Writing chapter data 

6.4.2 Chapters Avspmod 

You can also create chapters in AvsPmod however you will probably only use this 

method if you are encoding. To use this method, load in the premux using 

FFVideoSource. Once loaded, locate the frames where you want to set chapters and 

bookmark them with ctrl + B. Once all of the bookmarks have been set, convert them to 

chapters from Macros -> Bookmarks to Chapters. 

Once exported, open the .txt file in mkvmerge’s Chapter Editor and set the name and 

language. If you will be using ordered chapters, you can also write the Segment UID of 

the video file. When you are done, save the chapters from Chapter Editor -> save. To 

load the chapters into mkvmerge, navigate to the Global tab and add the chapter file 

toward the bottom of the window. 

6.5 Final Checking 

Once the video has been muxed, it is recommended that you review the video file in a 

clean environment. This can be done on a computer or virtual machine without any 

fonts installed. 
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7. Checklist 

1. Check and adjust script to use the same color space. 

2. Check and adjust script resolution. 

3. Check for style conflicts. 

4. Raise dialogue to a layer above typesetting. 

5. Merge. 

6. Write script properties. 

7. Review timings for inconsistencies. 

8. Remove comments and garbage data. 

9. Run a spell checker on the dialogue. 

10. Remove extradata (optional). 

11. Run font collector. 

12. Make and check chapters for consistency. 

13. Input files in the correct order into mkvmerge. 

14. Write CRC and check RC in clean environment. 


